Cannot update firmware even daemon is stopped

Support for the UPS PIco HV3.0A, HV3.0B and HV3.0B+, as also Terminal Block products, SD images also for updated hardware HV3.0A/B/B+
Post Reply
phamd4
Posts: 1
Joined: Mon Feb 20, 2017 4:21 pm

Cannot update firmware even daemon is stopped

Post by phamd4 » Sat Oct 28, 2017 4:43 am

Hello,

I have tried to figured out the problem by myself the the past 14 hours however I just can't seems to get to the last step to get to the upgrade for the firmware. I did follow every step in every version of the manual my is at 18 rightnow and even when i tried to upgrade to the next one which is 24 it still wouldn't let me upgrade. I have stopped the daemon like the manual suggested, bluetooth disable, and tty.. stopped, however i kept getting the error of no being communicate with the serial port and if it is available. The orange light is on I've tried the hardware and software they both go in to the flash mode but I can't seems to get it to work.

I included a screen shot of my code. I hope you guys can help me out

Much appreciated.
reduced 1.jpg
reduced 1.jpg (152.42 KiB) Viewed 1145 times
reduced 2.jpg
reduced 2.jpg (84 KiB) Viewed 1145 times
ggm61
Posts: 3
Joined: Mon Oct 23, 2017 10:52 am

Re: Cannot update firmware even daemon is stopped

Post by ggm61 » Wed Nov 15, 2017 4:03 pm

Hi,

I had the same problem with a fresh new raspbian install (I read and follow these steps carrefully).
I had to use the Latest NOOBS with all PIco software installed - 8GB image to update the firmware successfully.

I hope it can help.

Best regards,
Jerome.
User avatar
cresfang
Posts: 87
Joined: Mon Aug 29, 2016 11:43 am
Location: Garden of Time

Re: Cannot update firmware even daemon is stopped

Post by cresfang » Wed Jan 03, 2018 3:53 am

Follow my instructions over here, WITH my modified script:

http://www.forum.pimodules.com/viewtopi ... =27&t=6964
Post Reply