DO NOT UPDATE TO BRANCH=next KERNEL!!

Support for the UPS PIco HV3.0A, HV3.0B and HV3.0B+, as also Terminal Block products, SD images also for updated hardware HV3.0A/B/B+
User avatar
Pimaster
Site Admin
Posts: 1615
Joined: Fri Sep 14, 2012 9:50 am

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by Pimaster » Tue Feb 28, 2017 5:18 pm

cresfang wrote:
Pimaster wrote:You can increase the speed up to 70K, still working perfectly. Higher that 75 has a problem
I suggest to set it at 50 000, work well, and fast enough
Yess boss 8-)

I'm testing 50k right now as well ;)

EDIT: 50k gives me 0xff and all that errors... and reverting to 10k + reboot now giving strange fw ver: 69

UPS PIco Firmware....: 69
UPS PIco Bootloader...: 50
UPS PIco PCB Version..: 41
It is timing problem, and I2C setup on our side. They made the I2C clock calculation in a different way (proper one). Remember that we are running a huge interrupt service routing on each i2c byte (3 uS)
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
User avatar
cresfang
Posts: 87
Joined: Mon Aug 29, 2016 11:43 am
Location: Garden of Time

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by cresfang » Wed Mar 01, 2017 5:28 am

Pimaster wrote:It is timing problem, and I2C setup on our side. They made the I2C clock calculation in a different way (proper one). Remember that we are running a huge interrupt service routing on each i2c byte (3 uS)
so for now I'll stick to 10k, its working perfectly.... ;)
and for the fw ver issue, I just reset the UPS using UR button...
now it shows correct fw ver (24)....

tell me if you need any help... ;)
jbaumann
Posts: 6
Joined: Thu May 26, 2016 9:34 pm

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by jbaumann » Sun Mar 12, 2017 5:06 pm

Even though I own one of the 1.1 version of the UPS Pico, the problem was the same, and the solution works without a problem. Thanks a lot for the solution.

Regards, Joachim
User avatar
Pimaster
Site Admin
Posts: 1615
Joined: Fri Sep 14, 2012 9:50 am

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by Pimaster » Sun Mar 12, 2017 9:04 pm

Hi,
I know. We have already solved it for the HV3.0 and for the HV1.0/1. We are planning to release new firmware for the HV1.1/0 just after we complete the HV3.0 moving the biggest part fo firmware to the old one. We are still not able to support the old HV1.1 forum due thousands not moderated posts, please be pationt little bit, until we activate this forum also.
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
tetzlav
Posts: 4
Joined: Sun Sep 27, 2015 12:50 pm

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by tetzlav » Wed Aug 16, 2017 10:50 pm

just add

Code: Select all

dtoverlay=i2c-bcm2708
to /boot/config.txt to reactivate the old driver and the pico reads will working again... ;)
Last edited by tetzlav on Fri Sep 08, 2017 11:15 pm, edited 1 time in total.
User avatar
Pimaster
Site Admin
Posts: 1615
Joined: Fri Sep 14, 2012 9:50 am

Re: DO NOT UPDATE TO BRANCH=next KERNEL!!

Post by Pimaster » Sun Aug 20, 2017 6:05 pm

thank you !!
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
Post Reply