[solved] Force charge deep discharged LiPo

Support for the UPS PIco HV3.0A, HV3.0B and HV3.0B+, as also Terminal Block products, SD images also for updated hardware HV3.0A/B/B+
Post Reply
bolausson
Posts: 28
Joined: Mon Mar 06, 2017 6:37 pm

[solved] Force charge deep discharged LiPo

Post by bolausson » Sun Nov 26, 2017 12:21 am

Hej,

one of my LiPo 450 mAh battery packs was not used for some time. Now I tried to start the UPS Pico HV3.0A Plus with that battery attached.

The outcome is the following:
  • PIco beeps every ~6 seconds
  • UPS LED blinks slowly
  • BAT LED is constantly lid (orange)
  • CHG LED off

Code: Select all

**********************************************
*             UPS PIco HV3.0A Status           *
*                  Version 5.0                 *
**********************************************
 
  UPS PIco Firmware.....: 30
  UPS PIco Bootloader...: 50
  UPS PIco PCB Version..: 41
  UPS PIco BATT Version.: LiPO (ASCII: P)
  UPS PIco BATT Runtime.: 1 MIN
  UPS PIco rs232 State..: OFF
 
  Powering Mode.........: BATT POWERED
  Charger State.........: ERROR
  Battery Percentage....: 100 %
  Battery Voltage.......: 2.1 V
  RPi Voltage...........: 0.0 V
  NTC1 Temperature......: 40 C
  TO-92 Temperature.....: 01 C
  Extended Voltage......: 0.0 V
  A/D2 Voltage..........: 0.0 V
 
  UPS PIco FAN Mode.....: ERROR
  UPS PIco FAN State....: OFF
  UPS PIco FAN Speed....: 3200 RPM
 
**********************************************
*           Powered by PiModules             *
**********************************************
Is there a way to force charge it? Or am I on a completely wrong track here?

Greetings,
Bjoern
Last edited by bolausson on Tue Nov 28, 2017 12:03 am, edited 1 time in total.
User avatar
Pimaster
Site Admin
Posts: 1615
Joined: Fri Sep 14, 2012 9:50 am

Re: Force charge deep discharged LiPo

Post by Pimaster » Sun Nov 26, 2017 1:35 am

Hi,
1. Please upload the latest version of firmware
2. Due to deep discharge, system is requesting more current, try to use better PSU
What kind of PSU do you have ?
We are working on dynamic charging algorithm but it is still not ready. It is ready on the version Plus, but their charger works different
Warmest Regards
PiM
---
Designing with Mentor Graphics PADS - www.pads.com
Please read and follow the PiForum rules
http://www.forum.pimodules.com/viewtopic.php?f=13&t=196
---
bolausson
Posts: 28
Joined: Mon Mar 06, 2017 6:37 pm

Re: Force charge deep discharged LiPo

Post by bolausson » Sun Nov 26, 2017 4:44 pm

Hej,

I updated to the latest firmware.
I was using a 2A power supply. I am now using a Y-Kable attached to two 2A PSUs - just to be sure.

But in the end, I think it was just a crap cable...

Thanks for your quick response!

Code: Select all

**********************************************
*      	    UPS PIco HV3.0A Status           *
*      	         Version 6.0                 *
**********************************************
 
  - PIco Firmware..........: 38
  - PIco Bootloader........: 50
  - PIco PCB Version.......: 41
  - PIco BAT Version.......: LiPO (ASCII: P)
  - PIco BAT Runtime.......: 1 MIN
  - PIco rs232 State.......: OFF
 
  - Powering Mode..........: RPi POWERED
  - Charger State..........: CHARGING
  - Battery Percentage.....: -33 %
  - Battery Voltage........: 3.1 V
  - RPi Voltage............: 5.3 V
 
  - RPi CPU Temperature....: 51.5 C
  - NTC1 Temperature.......: 40 C
  - PIco FAN Mode..........: AUTOMATIC
  - PIco FAN Temp Threshold: 35 C
 
**********************************************
*           Powered by PiModules             *
**********************************************
Cheers,
Bjoern
Post Reply